reveal not seeing device

Joan Molina's Avatar

Joan Molina

03 Oct, 2018 01:10 AM

hi, I tried with Reveal 11 and 18 with no luck.
In the simulator I have the message: INFO: Reveal Server started (Protocol Version 47).
I have Xcode 9.4.1 and Xcode 10 but 9.4.1 as CLI, I'm using Mojave.
And here is the steps for the bonjour guide:

dns-sd -B _reveal._tcp local
Browsing for _reveal._tcp.local
DATE: ---Wed 03 Oct 2018---
3:01:33.701 ...STARTING... Timestamp A/R Flags if Domain Service Type Instance Name
3:01:33.702 Add 2 -1 local. _reveal._tcp. Reveal--b8cbacb7 dns-sd -L Reveal--b8cbacb7 _reveal._tcp.
Lookup Reveal--b8cbacb7._reveal._tcp..local
DATE: ---Wed 03 Oct 2018---
3:04:22.569 ...STARTING... 3:04:22.570 Reveal--b8cbacb7._reveal._tcp.local. can be reached at localhost.:5976 (interface -1) isSim=true devSysName=iOS devSysVer=12.0 appExtTypeId= protoVer=47 appBundleId=fr.intact.birdee.dev appName=Birdee\ dev appIsExt=false appShortVers=2.0.5 devLocalModel=iPhone deviceID=iPhoneX-iOS-12.0 devName=iPhone\ X devModel=iPhone appVers=107

curl -s -D - http://localhost:5976/application -o /dev/null
HTTP/1.1 200 OK
Content-Type: application/json; charset=utf-8
Reveal-Protocol-Version: 47
Reveal-Device-Simulator: YES
Reveal-System-Name: iOS
Accept-Ranges: bytes
Date: Wed, 03 Oct 2018 01:04:47 GMT
Reveal-System-Version: 12.0
Content-Length: 1206731
Reveal-Device-Model: iPhone

Why I don't see it in Reveal? I used to, and the pod config or the scheme didn't change,
thanks

  1. 1 Posted by Joan Molina on 03 Oct, 2018 01:17 AM

    Joan Molina's Avatar

    I restored the /etc/hosts file, I don't know why it was empty... not it's working fine again

  2. Support Staff 2 Posted by Vlas Voloshin on 03 Oct, 2018 01:31 AM

    Vlas Voloshin's Avatar

    Hi Joan,

    I'm glad you've been able to resolve this issue by restoring /etc/hosts file. It's certainly curious that it turned out to be empty, especially if you don't remember modifying it yourself since the time Reveal worked. It's possible that you have some software on your machine that modified /etc/hosts behind your back. If this issue repeats, I'd definitely recommend checking whether some app or service you installed recently is responsible for that. But hopefully that won't be necessary!

    Best regards,
    Vlas.

  3. Vlas Voloshin closed this discussion on 03 Oct, 2018 01:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac