transferred to new mac and reveal can't see any apps running

Jason Wolkovitz's Avatar

Jason Wolkovitz

23 Aug, 2018 03:32 PM

I used the mac migration tool and now when I run the apps on the simulator reveal can't see them
I ran through the "Bonjour Debugging: Why can't I connect to my App?" guide and when I ran
curl -s -D - http://localhost:(nyPort)/application -o /dev/nul l it returned with no data the previous 2 steps work fine
tested on my old computer and it works fine

  1. Support Staff 1 Posted by Vlas Voloshin on 25 Aug, 2018 09:24 AM

    Vlas Voloshin's Avatar

    Hi Jason,

    I have a few suggestions that could help troubleshooting this issue:

    • Can you confirm that icons for apps on your new computer don't appear in Reveal's list of inspectable applications at all, as opposed to timing out when attempting to select them?
    • Have you tried inspecting apps running on a physical iOS device from your new computer?
    • It may be worth trying to reset the Simulator using HardwareErase All Content and Settings… menu, and running your app again.
    • If you have both your new and old computers running on the same network at the same time, but haven't changed the computer name on the new one after migrating, it's possible that Bonjour gets confused. Please open  → System Preferences… menu → Sharing on both computers, and check that Computer Name preference is different on them. You can use the Edit… button on that preference pane to change their local hostnames to unique values.
    • The fact that the curl command returned no response is strange. Can you try repeating the steps outlined in the Bonjour Debugging guide, but this time invoking the curl command this way?

      curl -D - http://localhost:<port>/application -o ~/Desktop/application.json

      With these parameters it's going to display any errors it might encounter in the process, as opposed to the silent mode enabled by the -s parameter, and also output the response body to application.json file on your Desktop. Of course, <port> needs to be replaced with the Reveal Server port you discover in the preceding steps of the debugging guide. Once you do this, please let me know what response do you see, and also whether application.json file appears (no need to attach the latter here at this point).

    • As the debugging guide suggests, do you by chance have a modified /etc/hosts file on your system? I understand that it would be strange if it worked on your old computer, but doesn't on the new one, but it's nevertheless a very common cause for connectivity issues with Reveal, so it's worth checking. localhost in that file must be mapped to it's normal address 127.0.0.1.

    • Finally, can you run this command in the Terminal and show me the results?

      dns-sd -G v4 localhost

    I'll be looking forward for your answer!

    Best regards,
    Vlas.

  2. 2 Posted by paul.lavoine on 07 Sep, 2018 10:17 AM

    paul.lavoine's Avatar

    Hello,

    I got the same problem. I followed your recommendation and the problem was in the file "/etc/host/"

    It has been erase during the mac migration.
    Good job @Vlas Voloshin

  3. 3 Posted by Nikolas Mayr on 07 Sep, 2018 10:28 AM

    Nikolas Mayr's Avatar

    I had the same problem. The file /etc/hosts was empty.
    I added the following line:

    127.0.0.1 localhost

    The problem was gone when restarting Reveal.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac