Can't Connect to Reveal Server in iOS 11+

Kyle Formeck's Avatar

Kyle Formeck

22 Mar, 2018 03:18 PM

To whom it may concern,

I have been using the Reveal app for about a year now and I love it. However, I haven't been able to use it since October or so, right around the time iOS 11 came out.

Every since the upgrade, I have not been able to connect my app to the Reveal Server.

I have this in my additional mtouch arguments in visual studio:
--framework:/Applications/Reveal.app/Contents/SharedSupport/iOS-Libraries/RevealServer.framework

When I run Reveal, it correctly finds the running application. However, when I attempt to connect to it, I get the error:
"The request timed out."

I have tried setting the connection time out to 30 seconds and 60 seconds and that doesn't work either. i.e.
defaults write com.ittybittyapps.Reveal2 IBAHierarchyRequestTimeout 30
defaults write com.ittybittyapps.Reveal2 IBAHierarchyRequestTimeout 60

I would love to be able to use this application again.

Reveal - v13 (10035)
Mac OS X - Sierra v10.12.6
Xamarin - v4.8.0.760
Xamarin.iOS - v11.6.1.4

Regards,

Kyle Formeck

  1. Support Staff 1 Posted by Tony Arnold on 26 Mar, 2018 10:10 PM

    Tony Arnold's Avatar

    Hi Kyle,

    It sounds like there might be something tripping up Reveal while it snapshots your view hierarchy. Is there anything in your console from Reveal when you connect to this app?

    You could try raising Reveal's logging level to see if that highlights any problems: http://support.revealapp.com/kb/tips-tricks/revealserver-configurat...

    thanks,

    Tony

  2. 2 Posted by Kyle Formeck on 28 Mar, 2018 03:38 PM

    Kyle Formeck's Avatar

    Tony,

    When I start my application, I see this in the debug output:

    'App.iOS[82866:2670354]  INFO: Reveal Server started (Protocol Version 42).'
    

    Then when I try to connect to the app using Reveal, I get 'The request timed out' error and there is nothing else in the console.

    I was unable to set IBARevealServerLogLevel; I am using Xamarin with Visual Studio 2017 on a Windows 10 PC and the instructions provided only explain how to set that up on XCode.

    So I tried anyways; I went to 'iOS Run Options' in the iOS app's project properties and tried setting the 'Start Arguments' and/or 'Extra mlaunch Arguments':

    • setting 'Start Arguments' to '-IBARevealServerLogLevel DEBUG' changed nothing
    • setting 'Extra mlaunch Arguments' to '-IBARevealServerLogLevel DEBUG' caused build errors:
    Severity Code    Description Project File    Line    Suppression State
    Error       error MT0010: Could not parse the command line arguments: System.AggregateException: One or more errors occurred. ---> Xamarin.Launcher.LauncherException: Unknown command line argument: '-IBARevealServerLogLevel'
       --- End of inner exception stack trace ---
      at Xamarin.Launcher.Driver.Main2 (System.String[] args) [0x009fa] in /Users/builder/data/lanes/5665/db807ec9/source/maciostools/Xamarin.Hosting/Xamarin.Launcher/Main.cs:409 
    ---> (Inner Exception #0) error MT0018: Unknown command line argument: '-IBARevealServerLogLevel'<---
    
    ---> (Inner Exception #1) error MT0018: Unknown command line argument: 'DEBUG'<---            0
    

    So I have run out of ideas. I have even setting the 'Additional mtouch Arguments' to
    -gcc_flags "-force_load /Applications/Reveal.app/Contents/SharedSupport/iOS-Libraries/RevealServer.framework/RevealServer" instead of --framework:/Applications/Reveal.app/Contents/SharedSupport/iOS-Libraries/RevealServer.framework.

    reference: https://forums.xamarin.com/discussion/38916/revealapp-working

    None of this works, is there anything I can try? Would uninstalling and re-installing it make a difference?

  3. Support Staff 3 Posted by Tony Arnold on 03 Apr, 2018 12:10 AM

    Tony Arnold's Avatar

    Hi Kyle,

    Are you trying to run Reveal against an app running in the iOS Simulator, or directly on a device?

    I'll have to re-install Xamarin and ensure our instructions are up-to-date - I checked them recently, but perhaps something has changed.

    thanks for your patience and understanding,

    Tony

  4. 4 Posted by Kyle Formeck on 03 Apr, 2018 01:53 PM

    Kyle Formeck's Avatar

    Tony,

    I am trying to run Reveal against an app running in the iOS simulator.

    I recently upgraded some libraries so here is my current environment:

    Reveal - v13 (10035)
    Mac OS X - Sierra v10.13.4*
    Xamarin - v4.9.0.752*
    Xamarin.iOS - v11.8.1.28*

    • = updated library
  5. Support Staff 5 Posted by Tony Arnold on 04 Apr, 2018 01:45 AM

    Tony Arnold's Avatar

    Hi Kyle, I'm really sorry about this - I've just run through creating a new project using the latest release of Visual Studio for Mac (7.4.2 build 12), and linked to Reveal using the mtouch argument as documented here: http://support.revealapp.com/kb/getting-started/integrating-reveal-...

    It's all worked fine.

    Is there any way I can get a copy of your project (or of any project) that demonstrates this problem?

    Also, could you post a copy of your /etc/hosts file back here for me?

    Thanks!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac