Reveal not connecting with my iOS Simulator

John Gee's Avatar

John Gee

29 Jan, 2018 11:55 PM

Hi,

I'm having trouble connecting Reveal with my iOS Simulator from XCode. Upon going through the debugging guide here: http://support.revealapp.com/kb/tips-tricks/bonjour-debugging-why-c..., I tried running the command

dns-sd -B _reveal._tcp local

and got the unexpected output that you can find in the attached file (I would wait there forever and tried Control + C as they suggest in the guide but there is no output like suggested in the guide). Further , I realized in my console that I get the "Month 13 is out of bounds" error multiple times, not sure if that is helpful information. Please help! Thanks for your time :)

Best,
John

  1. Support Staff 1 Posted by Tony Arnold on 30 Jan, 2018 10:16 PM

    Tony Arnold's Avatar

    Hi John, I'm sorry you're having troubles connecting your iOS app with Reveal. At the bottom of the article you linked, there's a section titled "Still Having Issues?" - I'd ask that you check point 3 in that list on your machine. Generally when there are issues with Bonjour resolving, they come back to a modified /etc/hosts file, or a firewall.

    thanks,

    Tony

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2018-01-29_at_3.52.18_PM.png 60 KB
  • Screen_Shot_2018-01-29_at_3.54.13_PM.png 197 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac