can't find app in reveal

run's Avatar

run

09 Aug, 2017 04:44 AM

i am using reveal via an Xcode Breakpoint.I follow the intergration guide step by step.When i run my app,the console print: INFO: Reveal Server started (Protocol Version 40).However,I can find my app in reveal list.Then i see the "Bonjour Debugging: Why can't I connect to my App?",I follow the guide to ensure whether reveal is being linked correctly,but everything is ok.My app is using the reveal service,and the http status is 200(ok),so i wonder why can'i i find my app in reveal list.Then i try to install reveal SDK via cocoaPod,but it also doesn't work.
In addition,I try to inspect your sample app,after the sample app is runing,i still can't find the sample app in reveal list.

  1. 1 Posted by run on 10 Aug, 2017 02:36 AM

    run's Avatar

    when i inspect the sample app,i still can't find the sample app in reveal list

  2. Support Staff 2 Posted by Tony Arnold on 13 Aug, 2017 10:37 PM

    Tony Arnold's Avatar

    Hello,

    You mentioned that you worked through our Bonjour Debugging Article - did you get all the way to the end of the document?

    Most commonly, we find users have modified the /etc/hosts document on their Mac to get around VPN or firewall restrictions - this interferes with how Reveal communicates.

    There is more detail about what to do if you're still having issues in the same document - can you confirm your /etc/hosts file is unmodified?

  3. 3 Posted by run on 17 Aug, 2017 01:53 PM

    run's Avatar

    I have modified the /etc/hosts document to get around VPN.but i contain content as follow pictures,that is my localhost.i havn't removed it.Is it have any problem?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac