Reveal 9 (9762) frequently failing to load via debugger command

Rand Arnold's Avatar

Rand Arnold

17 Jul, 2017 06:42 PM

I'm loading Reveal via an Xcode breakpoint file:///Applications/Reveal.app/Contents/SharedSupport/Documentation/Integrating%20Using%20Breakpoints.html

All was great until the new release of Reveal 9, now I frequently get a failure when I launch my app in the simulator:

Loading Reveal Server from /Applications/Reveal.app/Contents/SharedSupport/iOS-Libraries/RevealServer.framework/RevealServer...
error: unknown error

It will eventually load, but often I don't notice it not loading for a while, which is a pain when reproducing a bug…

macOS 10.12.5 (16F73), Xcode 8.3.3 (8E3004b), MBP (15-inch, 2016), DELL P2715Q display 3360x1890

Thank you,
Rand

  1. Support Staff 1 Posted by Tony Arnold on 17 Jul, 2017 11:32 PM

    Tony Arnold's Avatar

    Hi Rand,

    Sorry to hear this - I'll do my best to help work out what's happening.

    1. You mentioned the simulator - does this also happen on device?
    2. When you say "it will eventually load", does this require you to re-run your iOS app from within Xcode to make this happen, or does it just come up on it's own?

    Please check if the quarantine bit on Reveal has been removed by macOS by executing the following commands and looking for com.apple.quarantine:

    xattr /Applications/Reveal.app
    xattr /Applications/Reveal.app/Contents/SharedSupport/iOS-Libraries/RevealServer.framework/RevealServer
    

    thanks,

    Tony

  2. 2 Posted by Rand Arnold on 19 Jul, 2017 03:48 AM

    Rand Arnold's Avatar

    Hi Tony,

    1. For this project, I don’t have the library linked it (at least yet), so only the simulator. I’d have to double check my other app, I’m not sure I’ve run Reveal against it recently.

    2. Ah right, eventually meaning, run from Xcode over and over, sometimes seven launches. it seems to fail consistently for a while, then work fine for a while. I poked around for a few minutes to see if I could load reveal after the app was running, after a few unsuccessful tries I just went back to re-running from Xcode.

    com.apple.quarantine was not evident.

    Today I was working on my Mac Pro. Same results, however perhaps fewer failures to load.

    Thank you,
    Rand

  3. Support Staff 3 Posted by Tony Arnold on 24 Jul, 2017 12:10 AM

    Tony Arnold's Avatar

    Hi Rand,

    I'm sorry for the delay in replying.

    Could you try something for me? It may be that the LLDB commands we install aren't being recognised properly - this will reinstall them.

    1. Open Reveal
    2. Select the "Help → Remove Debugger Commands…", and follow the prompts to remove the commands
    3. Go back to the same menu item - it will be named "Install Debugger Commands…" now - go through the process to reinstall the commands
    4. Relaunch Xcode

    Failing that, it may be necessary to manually integrate Reveal's framework into your project to see if that still works.

    Thanks for your patience,

    Tony

  4. 4 Posted by Rand Arnold on 27 Jul, 2017 04:25 AM

    Rand Arnold's Avatar

    Hi Tony,

    I tried removing and reinstalling the debug commands, however it made no difference. I was able to get a pull request in to include the framework in the app however so I don’t anticipate any further issues.

    It might be a permissions issue, as while I was successful in the remove/add on my MBP, I was unsuccessful on my Mac Pro. Awe permissions…

    Anyway, thank you for an awesome product, making me look like a genius!

    Rand

  5. Support Staff 5 Posted by Tony Arnold on 27 Jul, 2017 05:17 AM

    Tony Arnold's Avatar

    Thanks for letting me know, Rand! Permissions could definitely cause issues that would prevent the library from loading, but it is puzzling that it worked some of the time.

    Anyhow, I'm glad to hear you are up and running! Let me know if there's anything else I can do to help.

  6. Tony Arnold closed this discussion on 27 Jul, 2017 05:17 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac