Can't see UI Elements in Canvas too

Andrey's Avatar


11 Jul, 2017 10:58 PM

Good day!

You are making an excellent product! But some days ago I faced the same problem that described here:

As opposed to Chris, I have a licensed MacBook Air 2010. And this problem occured after updating my Mac to macOS Sierra 10.12.5 and XCode to 8.3.3 (8E3004b).
Version of Reveal is 8 (9667) (license is still active too). I tried to update Reveal, but button "Check for Updates..." is inactive.
I downloaded the latest version (9) from the site, but nothing changed. Only button "Check for Updates..." now active.
Could You help me?



  1. Support Staff 1 Posted by Tony Arnold on 11 Jul, 2017 11:02 PM

    Tony Arnold's Avatar

    Hi Andrey,

    That's not good - this should all work on a MacBook Air.

    As a quick test: if you open a book in iBooks, does it display correctly?



  2. 2 Posted by Andrey on 12 Jul, 2017 11:48 AM

    Andrey's Avatar

    Hi Tony,

    Yes, iBooks doesn't work correctly too. It seems, there are some problems with video driver for my NVIDIA GeForce 320M video card.
    I'll try to fix it at first.



  3. Support Staff 3 Posted by Tony Arnold on 12 Jul, 2017 11:50 AM

    Tony Arnold's Avatar

    It sounds to me like you've installed NVIDIA's web drivers. If you have, try uninstalling them, or switching back to the system-provided drivers via the NVIDIA system preferences pane - they're broken for apps that need to load Metal support.

  4. 4 Posted by Andrey on 12 Jul, 2017 03:30 PM

    Andrey's Avatar

    Oh, it's magic :)

    Now Reveal works perfectly!

    Thank you very much,


  5. Support Staff 5 Posted by Tony Arnold on 12 Jul, 2017 09:58 PM

    Tony Arnold's Avatar

    Great to hear, Andrey. Be sure to contact NVIDIA and let them know about the issue when you have time. I'd love to see them fix this issue, too!

  6. Tony Arnold closed this discussion on 12 Jul, 2017 09:58 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac