Error compiling with Reveal

Johan Hernandez's Avatar

Johan Hernandez

03 Jun, 2013 04:44 PM

I'm using static linking but the following errors is preventing me from running the app in the simulator:

dyld: Library not loaded: /Volumes/Data/JenkinsBuilds/Reveal-Hockey/workspace/build/Release-iphonesimulator/libReveal-iOS.dylib.tmp.i386
  Referenced from: /Users/thepumpkin/Library/Application Support/iPhone Simulator/6.1/Applications/E8A7E194-7BB4-4983-9A05-C103AA99158E/iphonetest1.app/iphonetest1
  Reason: image not found

Xcode 4.6.2 (4H1003)
iOS: 6.1
SDK: 6.1
(it's a brand new project)

  1. 1 Posted by Paulo Fierro on 03 Jun, 2013 04:53 PM

    Paulo Fierro's Avatar

    I'm getting the same thing when trying to run in the Simulator and on device:

    dyld: Library not loaded: /Volumes/Data/JenkinsBuilds/Reveal-Hockey/workspace/build/Release-iphoneos/libReveal-iOS.dylib.tmp.armv7s
    Reason: image not found

  2. Support Staff 2 Posted by Sean Woodhouse on 03 Jun, 2013 05:22 PM

    Sean Woodhouse's Avatar

    Hi guys,

    Are you following the 'Static Library Framework Integration' section of the integration guide, or the 'Dynamic Library Integration' section? You only need to do one or the other. If you're doing static linking you only need to link with Reveal.framework (not the libReveal.dylib).

    Let me know if that helps.

    Cheers

    Sean

  3. 3 Posted by Paulo Fierro on 03 Jun, 2013 05:30 PM

    Paulo Fierro's Avatar

    Was doing Static Library Framework Integration but I had added both the .framework and the .dylib.

    Removing the .dylib fixed it. Should have paid closer attention to the guide. Thanks :)

  4. 4 Posted by Johan Hernandez on 03 Jun, 2013 05:31 PM

    Johan Hernandez's Avatar

    Solved. Thanks.

  5. Support Staff 5 Posted by Sean Woodhouse on 03 Jun, 2013 05:34 PM

    Sean Woodhouse's Avatar

    Awesome, thanks for the feedback guys.

  6. Sean Woodhouse closed this discussion on 03 Jun, 2013 05:34 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac